Problem generating html.

I've got a change I want to commit to the edge docs but I'm running
into problems generating html.

With ruby 1.9.1 I get the following (I had to install several gems to
get this far.)

marquis@shiny:railties$ rake generate_guides ONLY=routing
(in /Users/marquis/programming/rails/dev/docrails/railties)
rake aborted!
spec pg-0.8.0 is not from an installed gem
/Users/marquis/programming/rails/dev/docrails/railties/Rakefile:1:in
`require'
(See full trace by running task with --trace)

I tried ruby 1.8.7 with less stellar results.

marquis@shiny:railties$ rake generate_guides ONLY=routing
(in /Users/marquis/programming/rails/dev/docrails/railties)
/Users/marquis/.rvm/rubies/ruby-1.8.7-p249/bin/ruby guides/
rails_guides.rb
/Users/marquis/.rvm/gems/ruby-1.8.7-p249/gems/actionpack-2.3.5/lib/
action_controller/cgi_ext/stdinput.rb:14:in `included': undefined
method `alias_method_chain' for CGI:Class (NoMethodError)
  from /Users/marquis/.rvm/gems/ruby-1.8.7-p249/gems/actionpack-2.3.5/
lib/action_controller/cgi_ext.rb:6:in `include'
  from /Users/marquis/.rvm/gems/ruby-1.8.7-p249/gems/actionpack-2.3.5/
lib/action_controller/cgi_ext.rb:6
  from /Users/marquis/.rvm/rubies/ruby-1.8.7-p249/lib/ruby/site_ruby/
1.8/rubygems/custom_require.rb:31:in `gem_original_require'
  from /Users/marquis/.rvm/rubies/ruby-1.8.7-p249/lib/ruby/site_ruby/
1.8/rubygems/custom_require.rb:31:in `require'
  from /Users/marquis/.rvm/gems/ruby-1.8.7-p249/gems/actionpack-2.3.5/
lib/action_controller.rb:36
  from /Users/marquis/.rvm/rubies/ruby-1.8.7-p249/lib/ruby/site_ruby/
1.8/rubygems/custom_require.rb:31:in `gem_original_require'
  from /Users/marquis/.rvm/rubies/ruby-1.8.7-p249/lib/ruby/site_ruby/
1.8/rubygems/custom_require.rb:31:in `require'
  from guides/rails_guides.rb:19
rake aborted!
Command failed with status (1): [/Users/marquis/.rvm/rubies/ruby-1.8.7-
p249...]
/Users/marquis/programming/rails/dev/docrails/railties/Rakefile:61
(See full trace by running task with --trace)

(If someone wants to get my change out I pasted it here:
http://pastie.org/private/vylp73kannquhm4sxsckzw )

As a workaround could you please try

   ruby guides/rails_guides.rb

from within railties?

Thanks for your contributions!

I got another error.

marquis@shiny:railties$ ruby guides/rails_guides.rb
Generating 2_2_release_notes
/Users/marquis/.rvm/gems/ruby-1.9.1-p378/gems/actionpack-3.0.0.beta/
lib/action_view/helpers/capture_helper.rb:147:in `with_output_buffer':
undefined method `encoding' for nil:NilClass (NoMethodError)
  from /Users/marquis/.rvm/gems/ruby-1.9.1-p378/gems/
actionpack-3.0.0.beta/lib/action_view/helpers/capture_helper.rb:39:in
`capture'
  from /Users/marquis/.rvm/gems/ruby-1.9.1-p378/gems/
actionpack-3.0.0.beta/lib/action_view/helpers/capture_helper.rb:115:in
`content_for'
  from /Users/marquis/programming/rails/dev/docrails/railties/guides/
rails_guides/generator.rb:78:in `set_header_section'
  from /Users/marquis/programming/rails/dev/docrails/railties/guides/
rails_guides/generator.rb:56:in `block in generate_guide'
  from /Users/marquis/programming/rails/dev/docrails/railties/guides/
rails_guides/generator.rb:46:in `open'
  from /Users/marquis/programming/rails/dev/docrails/railties/guides/
rails_guides/generator.rb:46:in `generate_guide'
  from /Users/marquis/programming/rails/dev/docrails/railties/guides/
rails_guides/generator.rb:31:in `block in generate'
  from /Users/marquis/programming/rails/dev/docrails/railties/guides/
rails_guides/generator.rb:30:in `each'
  from /Users/marquis/programming/rails/dev/docrails/railties/guides/
rails_guides/generator.rb:30:in `generate'
  from guides/rails_guides.rb:43:in `<main>'

It should work now in 1.9 and 1.8. Guides generation uses edge Action
Pack and breakages happen sometimes.