port 3000 on apache

this may be more of a web server question...

i can see:

http://localhost
http://localhost:3000
http://127.0.0.1
http://127.0.0.1:3000
http://192.168.16.128 (localhost ip address)
http://hostname (localhost name)

i CAN'T see:

http://192.168.16.128:3000
http://hostname:3000

what is wrong? is it a web server (apache2) configuration???

Yes this is a apache issue.

Please post the httpd.conf file.

If you are trying to forward requests to port 3000 using apache take a
look at mod_proxy... Doing something like this:

<Proxy balancer://rails_cluster>
        BalancerMember http://127.0.0.1:3000
</Proxy>

<VirtualHost *:80>
ProxyPass / balancer://my_cluster/
ProxyPassReverse / balancer://my_cluster/

more stuff...

</VirtualHost>

this may be more of a web server question...

i can see:

http://localhost
http://localhost:3000
http://127.0.0.1
http://127.0.0.1:3000
http://192.168.16.128 (localhost ip address)
http://hostname (localhost name)

i CAN'T see:

http://192.168.16.128:3000
http://hostname:3000

what is wrong? is it a web server (apache2) configuration???

Possibly. Could also be a firewall problem. It wouldn't be that
surprising if there were rules to the effect of 'allow anything on
the loopback interface', 'only allow port 80 on other interfaces'

Fred

Might be because he’s binding it to 127.0.0.1. Try specifying -b 0.0.0.0. It looks to me like you’re running a standard Rails server.

heimdull wrote:

Yes this is a apache issue.

Please post the httpd.conf file.

If you are trying to forward requests to port 3000 using apache take a
look at mod_proxy... Doing something like this:

<Proxy balancer://rails_cluster>
        BalancerMember http://127.0.0.1:3000
</Proxy>

<VirtualHost *:80>
ProxyPass / balancer://my_cluster/
ProxyPassReverse / balancer://my_cluster/

more stuff...

</VirtualHost>

apache2 doesn't have an httpd.conf file... what exactly are you looking
for? i'm not trying to forward requests to port 3000. i just want to be
able to access:

http://192.168.16.128:3000
http://hostname:3000

so that i can see the site from anywhere on my lan.

Ryan Bigg wrote:

Might be because he's binding it to 127.0.0.1. Try specifying -b
0.0.0.0. It
looks to me like you're running a standard Rails server.

--
Ryan Bigg
http://www.frozenplague.net
Feel free to add me to MSN and/or GTalk as this email.

hi ryan,

could you be more specific? i'm not sure what you mean by "specifying -b
0.0.0.0"
is this a command line option? what command?

thanks!

Frederick Cheung wrote: