Plugin Installing Issue

Hello guys,
Im new to RoR, and i was trying to make some thing with auto_complete…
But i can’t install auto_complete plugin : https://github.com/rails/auto_complete
I have tried to install others plugins and it always gives me the message : Plugin not found: [“https://github.com/rails/auto_complete.git”] or Plugin not found: [“http://svn.rubyonrails.org/rails/plugins/auto_complete”]

Does anyone know how to solve this issue?
Maybe installing it manually, does any one know how to do?

Thanks

Fernando

Which OS are you using, and have you installed git?

Colin

Hello Colin,

Im using Windows 7 Ultimate, Ruby 1.8.7 and Rails 2.3.5…

No… i haven’t installed it manually, but… doesnt it comes with rails? because there’s a git.rb in the folder C:\Ruby187\lib\ruby\gems\1.8\gems\rails-2.3.5\lib\rails_generator\generators\applications\app\scm.

Thanks for helping

Fernando

No.. i haven't installed it manually, but... doesnt it comes with rails?

No. You need to install it.

because there's a git.rb in the folder

You *can* open that up and read it, you know :slight_smile:

I have just installed git via msysGit, it even changed my windows command promt style…

but i still trying to execute ruby script/plugin install http://github.com/rails/auto_complete.git/ and i get the same error… it says Plugin not found…

Im executing this at my project’s folder, is it right, isnt it?

Yes, you need to execute the command inside your project folder, but
you also need to use a git URL.

Try this:

ruby script/plugin install git://github.com/rails/auto_complete.git

Sorry I can't help in that case, Rails on Windows is fraught with
difficultly I believe. I think that most here would suggest you look
at Ubuntu (or mac) if you are serious about Rails. The PC can easily
be setup to dual boot so you do not loose windows, though I can
virtually guarantee you find yourself using it less and less. An
alternative is Virtual Rails I believe which runs in a virtual machine
in windows.

Colin

Resolved!

the script/plugin install is still not working but i could install plugins using git clone git://github.com/rails/auto_complete.git

Thanks!

Fernando Leandro wrote in post #970481:

Resolved!

the script/plugin install is still not working but i could install
plugins
using git clone git://github.com/rails/auto_complete.git

That's not resolved, then. script/plugin install does more than git
clone. Get it working.

Thanks!

Best,

Hum… so thats why my i cant get my auto_complete working…

probably, ‘git clone’ doesnt install the plugin correctly…

does anyone have any idea of my problem, i installed git (git version 1.7.3.1) and i still always get the Plugin not found error…

does anyone have a suggestion?