PHP app on the same server as Rails app

I'd set each app up on it's own subdomain. But if you can't you can
use mod_rewrite to sort out where requests should go.

http://httpd.apache.org/docs/2.2/mod/mod_rewrite.html

I would assume that you are using passenger...

Just setup the rails app like normal then create a locations element
for the blog and turn off rails for this directory

And here is the cut'n paste from the Passenger documentation

<VirtualHost *:80>
    ServerName www.foo.com
    DocumentRoot /apps/foo/public
    <Directory /apps/foo/public/wordpress>
        PassengerEnabled off
        AllowOverride all # <-- Makes Wordpress's .htaccess file
work.
    </Directory>
</VirtualHost>

heimdull wrote:

I would assume that you are using passenger...

Just setup the rails app like normal then create a locations element
for the blog and turn off rails for this directory

And here is the cut'n paste from the Passenger documentation

<VirtualHost *:80>
    ServerName www.foo.com
    DocumentRoot /apps/foo/public
    <Directory /apps/foo/public/wordpress>
        PassengerEnabled off
        AllowOverride all # <-- Makes Wordpress's .htaccess file
work.
    </Directory>
</VirtualHost>

I'm using mongrel cluster behind Apache. It is a WP blog. I'm on
MediaTemple host and the way they set it up there is no DocumentRoot
specified in httpd.conf. Is there anyway to tell Apache not to send the
request to mongrel (like PassengerEnabled)?

http://kb.mediatemple.net/questions/279/Ruby+on+Rails+using+Mongrel+Clusters

It looks like there's a part about setting up your vhost.conf. Did you
go through these steps? If so, I'd guess that it's the place you want
to make your edits to exclude blog URL from being redirected.

Thanks to everyone for the help.

Indeed my problem was that I needed to re-install the WP blog like
Simone suggested. Now my subdomain works as expected.