PGError "unknown column" on polymorphic association column

Hi all !

This is very strange. I am attempting to get my application running on PostgreSQL (from MySQL), and I get this error:

ActiveRecord::StatementInvalid: PGError: ERREUR: la colonne «Party» n'existe pas : SELECT * FROM contact_routes WHERE (routable_type = "Party" AND routable_id = 1000013) ORDER BY position DESC LIMIT 1     /home/francois/src/ `log'     /home/francois/src/ `execute'     /home/francois/src/ `select'     /home/francois/src/ `select_all'     /home/francois/src/ `find_by_sql'     /home/francois/src/ `find_every'     /home/francois/src/ `find_initial'     /home/francois/src/ `find'

It translates to "The Party column does not exist". I ran the statement in psql, and sure enough, I get the same error. If I quote the routable_type column's value using single-quotes, I get the expected results.

My models look like this:

class Party < AR::B   has_many :contact_routes, :as => :routable end

class ContactRoute < AR::B   acts_as_list   belongs_to :routable, :polymorphic => true end

I'm on the 1.2 stable branch, using Ruby 1.8.4 and PostgreSQL 8.1.

Thanks !