performance test fails with error message

Simple performance test, I have installed ruby-prof and no other gems
are missing,

rake test:profile returns the following error.

line 18 in environment.rb is simple..

    config.logger = CustomLogger.new(config.log_path,
config.log_level)

Why is it coughing here?

This is REE 1.8.7 on rails 2.3.5

** Invoke test:profile (first_time)
** Invoke db:test:prepare (first_time)
** Invoke db:abort_if_pending_migrations (first_time)
** Invoke environment (first_time)
** Execute environment
** Execute db:abort_if_pending_migrations
** Execute db:test:prepare
** Invoke db:test:load (first_time)
** Invoke db:test:purge (first_time)
** Invoke environment
** Execute db:test:purge
** Execute db:test:load
** Invoke db:schema:load (first_time)
** Invoke environment
** Execute db:schema:load
** Execute test:profile
/usr/local/bin/ruby -I"lib:test" "/usr/local/lib/ruby/gems/1.8/gems/
rake-0.8.7/lib/rake/rake_test_loader.rb" "test/performance/
browsing_test.rb"
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/
active_support/dependencies.rb:105:in `const_missing': uninitialized
constant ActiveSupport::BufferedLogger::FileUtils (NameError)
  from /usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/
active_support/buffered_logger.rb:51:in `initialize'
  from /home/username/Apps/app_name/config/environment.rb:18:in `new'
  from /home/username/Apps/app_name/config/environment.rb:18
  from /usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
111:in `run'
  from /home/username/Apps/app_name/config/environment.rb:10
  from ./test/test_helper.rb:2:in `require'
  from ./test/test_helper.rb:2
  from ./test/performance/browsing_test.rb:1:in `require'
  from ./test/performance/browsing_test.rb:1
  from /usr/local/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake/
rake_test_loader.rb:5:in `load'
  from /usr/local/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake/
rake_test_loader.rb:5
  from /usr/local/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake/
rake_test_loader.rb:5:in `each'
  from /usr/local/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake/
rake_test_loader.rb:5
rake aborted!
Command failed with status (1): [/usr/local/bin/ruby -I"lib:test" "/
usr/loc...]

Simple performance test, I have installed ruby-prof and no other gems
are missing,

rake test:profile returns the following error.

line 18 in environment.rb is simple..

config\.logger = CustomLogger\.new\(config\.log\_path,

config.log_level)

I don't know what CustomLogger is but I suppose it's possible you're
trying to use a portion of the active support framework (ie buffered
logger) before activesupport has actually been loaded properly. It
does look like you might be able to fix it just by requiring fileutils
earlier on.

Fred