Patch to make GemDependency 'require' optional

I was moving our app's gem dependency checking off our homegrown
system and into 2.1's gem.config. However, gems like 'qrp' don't have
any libraries to require. Here's a patch:

http://rails.lighthouseapp.com/projects/8994-ruby-on-rails/tickets/743-make-require-on-gem-dependencies-optional

Which gives us:

config.gem "qrp", :version => "0.4.1", :lib => false

Looking for +1's.