passenger and apache mpm's

Hi!
Is it safe to run phusion passenger with all apache kinds of MPM?

regards

Prefork and Worker are supported.

Thanks for replying Hongli.
But, even with worker mpm installed, passenger installation asks me to
install development headers and apxs2 binary for apache2-mpm-prefork.
Why is that?

Hongli Lai wrote: