Paperclip permission denied error

I am hoping someone could shed some light on this problem.

I am setting up a new server to host a Rails app and it is almost done.
The only error I'm getting is permission denied when the Paperclip
plugin uploads the image and attempts to move it to its final location.
It can upload to the temp folder without problem and execute the
ImageMagick commands without a problem.

It is the same folder structure as my old server.... Old server apache
ran as "nobody". New server I am not sure. From what I can tell it runs
under "daemon", but I've tried these permissions with no success:

I've tried different ownerships and permissions on the folders:
Ownership: nobody
Ownership: daemon
Ownership: root

  Folder/File permissions: 755 and 777

Nothing has allowed it to move the uploaded image to the final folder.

I've been looking at this took long after a long hard fought battle with
ImageMagick installation issues.

Thanks for any insight,

Chris

?! "not sure"? Use `ps` and find out. Then su to that user and try the
operation manually.

?! "not sure"? Use `ps` and find out. Then su to that user and try the
operation manually.

--
Hassan Schroeder ------------------------ hassan.schroeder@gmail.com
twitter: @hassan

I've checked the users...

ruby runs under root
passenger runs under root
httpd runs under daemon

I've had the folder permissions set to 777 and ownership changed to
daemon and to root and still reports a permission denied error.

I have my folder for temporary upload files owned by daemon and it works
fine.

I have the production.log file owned by daemon and it can write to that
file.

But still can't seem to find the right ownership/permissions to allow
new folders and files created after upload.

Very odd.

It is "daemon". Not sure why previous attempts of giving
ownership/permission didn't work, but I backtracked through the folder
structure (nested quite deep on this Bitnami Rubystack) and made sure
the entire folder path allowed daemon write permissions.

Finally!!!

Chris