Paginator prob

i am trying to implement the pagination solution for ferret provided
at the following link:
http://www.railsenvy.com/2007/2/19/acts-as-ferret-tutorial#what

i am getting the following error:
uninitialized constant ApplicationController::Paginator

here is the call to paginator:
  pages = Paginator.new self, size, options[:per_page], (params[:page]||
1)

i echoed all of the inputs and they are not nil. i am not sure where
the errror is coming from.

i thought it was bc i did not have paginayor gem but i installed it
and i stil am getting the same error

I don't see, why you want to use this Paginator thing (whatever
exactly it is)
Ferret doesn't need it for pagination, you can give it the per_page &
page
options and that's all to it.

btw: Sphinx would most likely do a better job. Ferret is nice, until
you
try to make it run in production.

That code looks like it's trying to use the old classic_pagination
code (which was pushed into a plugin of the same name)

Fred

veering off topic… what does “Ferret is nice, until you try to make it run in production.” mean exactly? i’ve seen mention that ferret has problems in production but i don’t understand what other use you’d want it for. just to develop an idea but never put into production?

agreed on sphinx being a better solution though. my recommendation would be thinking sphinx.

RSL

exactly the point. you develop an idea, want to run it in
production and have a hell of a time. I've used ferret only in two
projects. Project one was very simple and we had no problems.
The other project was a bit more complex, no problems in
development, but when we put it in production, the index update
failed totally, missing to add things to the index, even after
full reindexing the whole dataset. We didn't give it too much
time though, so such issues may be solvable.
But to switch the whole thing to sphinx was a matter of a day or two
(with no previous knowledge of Sphinx) and it worked in production
as in development right away. Ok, a bit more work to setup everything,
but since then running (several months now) without the least trouble.

hmmmm....

so, do more people use sphinx for full text search?

i was just more comfortable using a lucence ruby port since lucene is
so well known

here is useful discussion on the issue:
https://groups.google.com/group/rubyonrails-deployment/browse_thread/thread/980fe7cb20cb97dd/bc798b52f439020c