openssl

Hello,
I have some kind of weird problem. I’d like to use new instalation of rails, I have installed the gems to the Ruby, then the Rails. When I use command script/generate there appear some error mesage, that I do not have openssl installed

As a solution to this problem I googled to install openssl development package…but I already had it!

Same problem is with this program passenger, it have a nice installation program. I ran it, it told me, what is missing in my system and sugested commands to fix it, all missing items were fixed after that, but this openssl thing is still missing - tels me the instalator.

Any ideas how to tell to ruby / rails that I actually have openssl installed?

regards
Jan Kadera

Hello,
I have some kind of weird problem. I'd like to use new instalation of rails,
I have installed the gems to the Ruby, then the Rails. When I use command
script/generate there appear some error mesage, that I do not have openssl
installed

As a solution to this problem I googled to install openssl development
package...but I already had it!

Same problem is with this program passenger, it have a nice installation
program. I ran it, it told me, what is missing in my system and sugested
commands to fix it, all missing items were fixed after that, but this
openssl thing is still missing - tels me the instalator.

Any ideas how to tell to ruby / rails that I actually have openssl
installed?

Do you have the ruby ssl extension ? Depending on how you installed
ruby you may not have this (particularly if at the time you installed
ruby you didn't have one of the prerequisites). If you installed ruby
via your package management system then there's usually a separate
package with the ruby openssl extension

Fred