nokogiri missing libiconv error. Chapter 3 of RoR book tutorial

Could it be that you are running OSX 10.6? I have the same problem, and
already contacted the nokogiri supporters. At least on *this* OSX
version. it doesn't work.

I have also informed Michael Hartl to consider this in the next update
of his tutorial. You will have to do without Capybara.