No route found to match "/dispatch.fcgi" with {:method=>:get}

Hello People,

I have a rails app on a subdomain that I'm proxying to Lightty. So far
so blah.

However, unlike my local set up, the "dispatch.fcgi" part of the URL
appears to be being passed to routes handler. My production.log is
full of stuff like this:

   1. Processing ApplicationController#login (for 62.136.183.60 at
2007-04-11 15:30:57) [GET]
   2. Session ID: 995579962d60492e4dd18ec08aff4265
   3. Parameters: {"action"=>"login", "controller"=>"application"}
   4. Rendering within layouts/application
   5. Rendering application/login
   6. Completed in 0.00776 (128 reqs/sec) | Rendering: 0.00722 (93%) |
DB: 0.00000 (0%) | 200 OK [<a href="http://MYDOMAIN/login">http://
MYDOMAIN/login</a>]
   7.
   8.
   9. Processing ApplicationController#index (for 62.136.183.60 at
2007-04-11 15:30:58) [GET]
  10. Session ID: 995579962d60492e4dd18ec08aff4265
  11. Parameters: {}
  12.
  13.
  14. ActionController::RoutingError (no route found to match "/
dispatch.fcgi" with {:method=>:get}):
  15. /vendor/rails/actionpack/lib/action_controller/routing.rb:
1292:in `recognize_path'
  16. /vendor/rails/actionpack/lib/action_controller/routing.rb:
1282:in `recognize'
  17. /vendor/rails/railties/lib/dispatcher.rb:40:in `dispatch'
  18. /vendor/rails/railties/lib/fcgi_handler.rb:168:in
`process_request'
  19. /vendor/rails/railties/lib/fcgi_handler.rb:143:in
`process_each_request!'
  20. /vendor/rails/railties/lib/fcgi_handler.rb:109:in
`with_signal_handler'
  21. /vendor/rails/railties/lib/fcgi_handler.rb:142:in
`process_each_request!'
  22. /usr/local/lib/ruby/gems/1.8/gems/fcgi-0.8.6.1/./fcgi.rb:600:in
`each_cgi'
  23. /usr/local/lib/ruby/gems/1.8/gems/fcgi-0.8.6.1/./fcgi.rb:597:in
`each'
  24. /usr/local/lib/ruby/gems/1.8/gems/fcgi-0.8.6.1/./fcgi.rb:597:in
`each_cgi'
  25. /vendor/rails/railties/lib/fcgi_handler.rb:141:in
`process_each_request!'
  26. /vendor/rails/railties/lib/fcgi_handler.rb:55:in `process!'
  27. /vendor/rails/railties/lib/fcgi_handler.rb:25:in `process!'
  28. /users/home/USERNAME/domains/MYDOMAIN/current/public/
dispatch.fcgi:24
  29.
  30.
  31. Rendering site/error
  32. no route found to match "/dispatch.fcgi" with {:method=>:get}
  33. /users/home/USERNAME/domains/MYDOMAIN/current/public/../
config/../vendor/rails/actionpack/lib/action_controller/routing.rb:
1292:in `recognize_path'
  34. /users/home/USERNAME/domains/MYDOMAIN/current/public/../
config/../vendor/rails/actionpack/lib/action_controller/routing.rb:
1282:in `recognize'
  35. /users/home/USERNAME/domains/MYDOMAIN/current/public/../
config/../vendor/rails/railties/lib/dispatcher.rb:40:in `dispatch'
  36. /users/home/USERNAME/domains/MYDOMAIN/current/public/../
config/../vendor/rails/railties/lib/fcgi_handler.rb:168:in
`process_request'
  37. /users/home/USERNAME/domains/MYDOMAIN/current/public/../
config/../vendor/rails/railties/lib/fcgi_handler.rb:143:in
`process_each_request!'
  38. /users/home/USERNAME/domains/MYDOMAIN/current/public/../
config/../vendor/rails/railties/lib/fcgi_handler.rb:109:in
`with_signal_handler'
  39. /users/home/USERNAME/domains/MYDOMAIN/current/public/../
config/../vendor/rails/railties/lib/fcgi_handler.rb:142:in
`process_each_request!'
  40. /usr/local/lib/ruby/gems/1.8/gems/fcgi-0.8.6.1/./fcgi.rb:600:in
`each_cgi'
  41. /usr/local/lib/ruby/gems/1.8/gems/fcgi-0.8.6.1/./fcgi.rb:597:in
`each'
  42. /usr/local/lib/ruby/gems/1.8/gems/fcgi-0.8.6.1/./fcgi.rb:597:in
`each_cgi'
  43. /users/home/USERNAME/domains/MYDOMAIN/current/public/../
config/../vendor/rails/railties/lib/fcgi_handler.rb:141:in
`process_each_request!'
  44. /users/home/USERNAME/domains/MYDOMAIN/current/public/../
config/../vendor/rails/railties/lib/fcgi_handler.rb:55:in `process!'
  45. /users/home/USERNAME/domains/MYDOMAIN/current/public/../
config/../vendor/rails/railties/lib/fcgi_handler.rb:25:in `process!'
  46. /users/home/USERNAME/domains/MYDOMAIN/current/public/
dispatch.fcgi:24
  47.
  48.
  49. Processing UnobtrusiveJavascriptController#generate (for
62.136.183.60 at 2007-04-11 15:30:59) [GET]
  50. Session ID: 995579962d60492e4dd18ec08aff4265
  51. Parameters: {"page_path"=>["login.js"], "action"=>"generate",
"controller"=>"unobtrusive_javascript"}
  52.
  53. Completed in 0.00042 (2364 reqs/sec) | Rendering: 0.00009 (20%)

DB: 0.00000 (0%) | 304 Not Modified <a href="http://MYDOMAIN/

behaviours/login.js">http://MYDOMAIN/behaviours/login.js</a>

My routes.rb looks like this:

   1. ActionController::Routing::Routes.draw do |map|
   2.
   3. map.home '', :controller => "site", :action => 'show'
   4.
   5. #administrivia
   6. map.login 'login', :controller => 'application', :action =>
'login'
   7. map.logout 'logout', :controller => 'application', :action =>
'logout'
   8. map.lost_password 'lost_password', :controller =>
'application', :action => 'lost_password'
   9. map.register 'register', :controller => 'application', :action
=> 'register'
  10.
  11. # site-specific
  12. map.members 'members/:action/:id', :controller => 'users'
  13. map.your 'members/you', :controller => 'users', :action =>
'self'
  14. map.forum 'forums', :controller => 'forum'
  15. map.feed 'feed', :controller => 'site', :action => 'feed'
  16. map.search 'search/*query', :controller => 'site', :action =>
'search'
  17.
  18. UJS::routes
  19.
  20. end

C'est bizarre. Any idea what's going on? Any suggestions gratefully
received. Cheers,