no route found to match "/cookbook/recipe/list" with {:method=>:get}

Hi,

I ve just spent about three hours trying to figure this out, so any
help would be appreciated.

I ve followed these steps:

1. Downloaded Instant Rails
2. Unzipped it
3. Ran "InstantRails.exe" to configure it. (path is c:\InstantRails)
4. Went to the "Manage Rails Applications" area and chose "cookbook"
app.
5. Clicked on "Start with Mongrel"
6. Mongrel was started and app was loaded on port 3001.
7. I opened a browser and typed "http://localhost:3000/cookbook/recipe/
list"

And I get this message:
"no route found to match "/cookbook/recipe/list" with {:method=>:get}"

Am I doing something wrong here? I appreciate your help very much.

Thanks a bunch, Ravil.

Your suggestion fixed it.

I’m not familiar with instant rails, but wouldn’t you want to use port 3001 if your app was started on that port?

Browse to http://localhost:3001/cookbook/recipe/ and it should work.

Curt

Hi,

I have spent almost my whole Sunday to fix the problem:

"no route found to match "/recipe/list" with {:method=>:get}", or
"no route found to match "/recipe" with {:method=>:get}"
depending on what I put into the browser.

I believe "http://localhost:3001/recipe/list should be the correct one.

I have tried everything and checked through my settings against the
tutorial many times. I still could Not solve the problem.

Could you please help where could go wrong?

Many Thanks!

Hi, if you’re using the default port, it should be 3000 instead 3001. Thus, I would try using the following:

http://localhost:3000/recipe/list

Good luck,

-Conrad

Thank you, Conrad!

After I started Mongrel, the application was loaded on port 3001.
Actually, my configuration steps were as the same as the 7 steps
provided in the orginal post of VolteFace at the top.

Any further information and advice on this could be very much
appreciated.

Please help and I really want a working installation to get me really
started with Rails.

Xiu

Is the controller called recipes?

Then it should be localhost:3001/recipes