no action responsed to a controller which works on local system, but in production

Hi,

can anyone tell me why I can't access
http://www.someurl.de/magazin/marketplace
but

http://www.someurl.de/magazin/marketplace/viewAdvertisement/1

I get the following msg: ActionController::UnknownAction (No action
responded to marketplace)

It works on my local osx, but not on the production linux comp

My routes file is looking like this:

ActionController::Routing::Routes.draw do |map|
   # The priority is based upon order of creation: first created ->
highest priority.

   # Sample of regular route:
   # map.connect 'products/:id', :controller => 'catalog', :action => 'view'
   # Keep in mind you can assign values other than :controller and :action

   # Sample of named route:
   # map.purchase 'products/:id/purchase', :controller => 'catalog',
:action => 'purchase'
   # This route can be invoked with purchase_url(:id => product.id)

   # You can have the root of your site routed by hooking up ''
   # -- just remember to delete public/index.html.
   map.connect '', :controller => "introduction", :action => 'index'
   map.connect 'sitemap.xml', :controller => 'MetaInformation', :action
=> 'sitemap'

   # Allow downloading Web Service WSDL as a file with an extension
   # instead of a file named 'wsdl'
   map.connect ':controller/service.wsdl', :action => 'wsdl'

   # Install the default route as the lowest priority.
   map.connect ':controller/:action/'
   map.connect ':controller/:controller/:action/'
   map.connect ':controller/:controller/:action/:id'
   map.connect ':controller/:action/:id.:format'
   map.connect ':controller/:action/:id'
end

Hopefully, anyone can help me !

Regards,
  Alex