nil.symbolize_keys -- error with attachment_fu

I've spent at least 2 hours on this one problem. On my local machine
in my controller I have this:

def new
    @page_title = "New User"
    @user =
    @photo =

All is good.
Now, on the remote server I get an error when accessing the 'new'
view. If I remove @photo = from the controller then the
error goes away. This same error is also happening on the create
method, even though it is the exact same code on my local machine.
Here is the error:

NoMethodError in UsersController#new

You have a nil object when you didn't expect it!
The error occurred while evaluating nil.symbolize_keys

attachment_fu/backends/s3_backend.rb:136:in `included'
attachment_fu.rb:79:in `include'
attachment_fu.rb:79:in `has_attachment'
#{RAILS_ROOT}/app/controllers/users_controller.rb:96:in `new'

I thought maybe the server cannot find my amazon_s3.yml file so I
added this attachment_fu option to the model:

:storage => :s3, :s3_config_path => (RAILS_ROOT + '/config/

But, same error :frowning:

Did you solve this problem? I get this error when switching to
production and not in development.

jko170 wrote: