Need security patches

Hi All,
I am using rails2.3.4 version ruby version 1.8.7 for my product.My client suggest me to apply if any security patches (security needs to be fixed in rails 2.3.4 & ruby 1.8.7) available. I dont know where and how should i find it.Please suggest me an idea or anyone knows any security patches for the same.

You should upgrade to the latest 2.3.x version of Rails. Or to
version 3 if you wish but that is more work. Make sure you have full
automated test coverage first so that you can be sure the upgrade has
not broken anything.

Colin