I'm having trouble naming my join models. The tables in question are:
- stores (list of company branches / stocking locations)
- items (inventory items)
- items_stores (item xyz is stocked by store_id 7, their re-order
point is 10, their sales price $27.50)
- items_locations (store_id 7 keeps part xyz on shelf B252)
While I believe items_stores would be proper naming for a HABTM type
relationship, everything I've found says to make up a new name for
has_many :through join models.
I'd be willing to change any of these names if someone can suggest an
Another issue I am confused about is the items_locations table. The
main reason I want this is to allow one store to keep a product in
multiple locations. Technically the locations information would be
associated with items_stores, but I don't think items_stores_locations
is a good name either.
Any suggestions would be really appreciated - I've been coming back to
this problem for a long time now without any real progress.