mysql gem recognized by script/server but not rake

Hi all,

I recently installed the ruby mysql gem (2.8.1) on my Mac Leopard
after much trouble (http://groups.google.com/group/rubyonrails-talk/
browse_thread/thread/586c29ca813cd391/fb5f34c8f9eb9e3f?lnk=gst&q=mysql
+gem#fb5f34c8f9eb9e3f)

Now, when I start up the Rails 2.3.5 application using script/server,
it connects to the database just fine. But when I run rake db:migrate,

!!! The bundled mysql.rb driver has been removed from Rails 2.2.
Please install the mysql gem and try again: gem install mysql.
rake aborted!
no such file to load -- mysql
/Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
/Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
/Users/ram/.gem/ruby/1.8/gems/activesupport-2.3.5/lib/active_support/
dependencies.rb:156:in `require'
...

Anybody got any idea why this is happening and how I can fix it?

Thanks!

Hi all,

I recently installed the ruby mysql gem (2.8.1) on my Mac Leopard
after much trouble (http://groups.google.com/group/rubyonrails-talk/
browse_thread/thread/586c29ca813cd391/fb5f34c8f9eb9e3f?lnk=gst&q=mysql
+gem#fb5f34c8f9eb9e3f)

Now, when I start up the Rails 2.3.5 application using script/server,
it connects to the database just fine. But when I run rake db:migrate,

It looks like from that other thread that you installed the mysql gem
in the ruby install in /usr/local but running rake is picking up the
rake in the other ruby install, presumably because you haven't
installed rake in the /usr/local install.

Fred

Hi Fred,

I actually checked that. Ran "gem list rake" and it listed 0.8.7 . I
also ran "gem update rake" but there were no updates to be made.

But now I uninstalled rake and then installed it again and its working
now :). Weird.

Thanks for your response!

Cheers,
Vinay.