Memcached: "no such file to load -- memcache-client" when running script/console

Hi folks. I've started down the memcached path and everything was
running grand until I decided to start up my console. I have manually
installed libevent 1.4.13 and memcached 1.4.4 into /usr/local,
following which I sudo gem installed memcache-client and SystemTimer.
development.rb has been modified to do caching with the
mem_cache_store.

The memcached process seems to work and my script/server starts up
fine. However, when I try script/console, I get the errors pasted at
the bottom of this post. If I test out some cache commands such as
Rails.cache.write('foo', 'bar'), Rails.cache.read('foo') they do work
correctly.

Any enlightenment appreciated.

Loading development environment (Rails 2.3.5)
no such file to load -- memcache-client
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/
active_support/dependencies.rb:156:in `require'
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/
active_support/dependencies.rb:521:in `new_constants_in'
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/
active_support/dependencies.rb:156:in `require'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/rails/
gem_dependency.rb:208:in `load'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
307:in `load_gems'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
307:in `each'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
307:in `load_gems'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
164:in `process'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
113:in `send'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
113:in `run'
/Users/yuval/Documents/webdev/pshpn/la/config/environment.rb:9
/usr/local/lib/ruby/1.8/irb/init.rb:252:in `require'
/usr/local/lib/ruby/1.8/irb/init.rb:252:in `load_modules'
/usr/local/lib/ruby/1.8/irb/init.rb:250:in `each'
/usr/local/lib/ruby/1.8/irb/init.rb:250:in `load_modules'
/usr/local/lib/ruby/1.8/irb/init.rb:21:in `setup'
/usr/local/lib/ruby/1.8/irb.rb:54:in `start'
/usr/local/bin/irb:13
no such file to load -- SystemTimer
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/
active_support/dependencies.rb:156:in `require'
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/
active_support/dependencies.rb:521:in `new_constants_in'
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/
active_support/dependencies.rb:156:in `require'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/rails/
gem_dependency.rb:208:in `load'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
307:in `load_gems'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
307:in `each'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
307:in `load_gems'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
164:in `process'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
113:in `send'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
113:in `run'
/Users/yuval/Documents/webdev/pshpn/la/config/environment.rb:9
/usr/local/lib/ruby/1.8/irb/init.rb:252:in `require'
/usr/local/lib/ruby/1.8/irb/init.rb:252:in `load_modules'
/usr/local/lib/ruby/1.8/irb/init.rb:250:in `each'
/usr/local/lib/ruby/1.8/irb/init.rb:250:in `load_modules'
/usr/local/lib/ruby/1.8/irb/init.rb:21:in `setup'
/usr/local/lib/ruby/1.8/irb.rb:54:in `start'
/usr/local/bin/irb:13
no such file to load -- memcache-client
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/
active_support/dependencies.rb:156:in `require'
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/
active_support/dependencies.rb:521:in `new_constants_in'
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/
active_support/dependencies.rb:156:in `require'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/rails/
gem_dependency.rb:208:in `load'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
307:in `load_gems'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
307:in `each'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
307:in `load_gems'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
169:in `process'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
113:in `send'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
113:in `run'
/Users/yuval/Documents/webdev/pshpn/la/config/environment.rb:9
/usr/local/lib/ruby/1.8/irb/init.rb:252:in `require'
/usr/local/lib/ruby/1.8/irb/init.rb:252:in `load_modules'
/usr/local/lib/ruby/1.8/irb/init.rb:250:in `each'
/usr/local/lib/ruby/1.8/irb/init.rb:250:in `load_modules'
/usr/local/lib/ruby/1.8/irb/init.rb:21:in `setup'
/usr/local/lib/ruby/1.8/irb.rb:54:in `start'
/usr/local/bin/irb:13
no such file to load -- SystemTimer
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/
active_support/dependencies.rb:156:in `require'
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/
active_support/dependencies.rb:521:in `new_constants_in'
/usr/local/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/
active_support/dependencies.rb:156:in `require'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/rails/
gem_dependency.rb:208:in `load'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
307:in `load_gems'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
307:in `each'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
307:in `load_gems'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
169:in `process'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
113:in `send'
/usr/local/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:
113:in `run'
/Users/yuval/Documents/webdev/pshpn/la/config/environment.rb:9
/usr/local/lib/ruby/1.8/irb/init.rb:252:in `require'
/usr/local/lib/ruby/1.8/irb/init.rb:252:in `load_modules'
/usr/local/lib/ruby/1.8/irb/init.rb:250:in `each'
/usr/local/lib/ruby/1.8/irb/init.rb:250:in `load_modules'
/usr/local/lib/ruby/1.8/irb/init.rb:21:in `setup'
/usr/local/lib/ruby/1.8/irb.rb:54:in `start'
/usr/local/bin/irb:13

I'd like to add that when I run script/server, I am getting the same
errors but only with SystemTimer.

This is what happens when you code at 2am. After banging my head
against the wall for half an hour, I discovered the error was due to a
typo in my config.gem requirements. Ugh, Goodnight.