MD5 wrong number of arguments (1 for 0) Error

Hi All,

I have following error on my Server which is working properly on my
local on following line .

event_id = MD5.new("event-init-flash-#{Asteroid::now}").to_s #line 232

ERROR: wrong number of arguments (1 for 0)
/ruby/gems/gems/shooting_star-3.2.7/bin/../lib/shooting_star/server.rb:232:in
`initialize'
/ruby/gems/gems/shooting_star-3.2.7/bin/../lib/shooting_star/server.rb:232:in
`new'
/ruby/gems/gems/shooting_star-3.2.7/bin/../lib/shooting_star/server.rb:232:in
`make_flash_connection'
/ruby/gems/gems/shooting_star-3.2.7/bin/../lib/shooting_star/server.rb:70:in
`receive_data'
/ruby/gems/gems/shooting_star-3.2.7/bin/../lib/shooting_star.rb:87:in
`run'
/ruby/gems/gems/shooting_star-3.2.7/bin/../lib/shooting_star.rb:87:in
`start'
/ruby/gems/gems/shooting_star-3.2.7/bin/shooting_star:61
/ruby/gems/bin/shooting_star:19:in `load'
/ruby/gems/bin/shooting_star:19
POST /10 HTTP/1.1
Host: 67.222.55.30:8080
Content-length: 103

I used shooting_star to create an Chat Application.
Ref:- http://github.com/genki/shooting-star
Following are the REQUIREMENTS of the shooting_star

* Linux or xBSD OS having epoll or kqueue.
* Increase ulimit of nofile up to over 100,000.
(edit /etc/security/limits.conf file.)
* prototype.js 1.5.0+
* Ruby 1.8.5+
* Ruby on Rails 1.2.0+

My Local Configuration are
O.S >> Linux
Ruby >> ruby 1.8.6 (2009-08-04 patchlevel 383) [i386-linux]
Rails >> 2.3.4
shooting_star >> 3.2.7
prototype.js >> 1.6.0.3

My Server Configuration are
O.S >> Linux
Ruby >> ruby 1.8.6 (2009-08-04 patchlevel 383) [x86_64-linux]
Rails >> 2.3.4
shooting_star >> 3.2.7
prototype.js >> 1.6.0.3

I just want to know what is the problem why it's not working on server
if everything is fine in local.

Regards,

Salil Gaikwad