Locomotive Terminal destroys my PATH!

I'm using Locomotive 2.0.8 on the Mac.

My .bash_profile - in its essence - looks like this:

  export PATH=.:$HOME/bin:/usr/local/bin:/usr/local/mysql/bin:$PATH

Now I found that when I open a Terminal from within Locomotive (i.e.
Applications/OpenTerminal), /usr/local/mysql/bin is missing from my
PATH (although ~/bin is there).

I traced what happens (set -x in .bash_profile) and found the
following:

First, my PATH is set in the expected way, i.e.

+ export PATH=.:/Users/fusshuhn/bin:/usr/local/bin:/usr/local/mysql/
bin:/bin:/sbin:/usr/bin:/usr/sbin

But after that, I see the following statement in the trace:

source /private/var/tmp/folders.501/TemporaryItems/2A10481D-7F30-4633-
A1DA-2EBB84EC987A-260-00000575DDDFE4E0.environment.bash

It seems that Locomotive has created a temporary file containing bash
commands,
which are now source (after my .bash_profile). During this process, I
see the
execution of the following command:

++ export PATH=/Applications/Locomotive2/Bundles/
standardRailsMar2007.locobundle/i386/bin:
/Applications/Locomotive2/Bundles/standardRailsMar2007.locobundle/i386/
sbin:
/Users/fusshuhn/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:

It is at this place, where my PATH is changed.

Interestingly, Locomotive *does* include my $HOME/bin. Historically,
my first version
of .bash_profile included only $HOME/bin in my PATH. Then I installed
Locomotive,
then I ran the Tools/Terminal.appStartupFixTool, and finally I
installed MySql and
updated .bash_profile so that it now contains also the directory /usr/
local/mysql/bin.
Could it be that Locomotive, does not recognized the changes I did in
my profile?
Well, I run the StarupFix Tool again, but no change: I still don't
have my MySql
directory included in my PATH...

Is this a bug in Locomotive?

Ronald