Learning ruby on Mac - rake create error

rake db:create:all works fine here:

/mystest 741 > mysql --version
mysql Ver 14.14 Distrib 5.1.31, for apple-darwin9.5.0 (powerpc) using
readline 5.1
/mystest 742 > gem list mysql

*** LOCAL GEMS ***

mysql (2.8.1)
/mystest 743 > cat config/database.yml
# MySQL. Versions 4.1 and 5.0 are recommended.

i was using sqlite for the past few projects and getting things
running smoothly enough
recently getting macports, git, installing a git module; geokit
turns out geokit has more functionality in mysql / postgress then
sqlite, namely distancing functions

i create the project as mysql, scaffold a location model then try to
run db:create
but i fail on rake db:create command

<code>
Couldn't create database for {"reconnect"=>false, "encoding"=>"utf8",
"username"=>"***", "adapter"=>"mysql", "database"=>"v3_development_2",
"pool"=>5, "password"=>"***", "socket"=>"/tmp/mysql.sock"}, charset:
utf8, collation: utf8_general_ci (if you set the charset manually,
make sure you have a matching collation)
</code>

*** used for username and password

i can login to mysql with the username and password
s displays current character set latin1
i can change to utf8, run the command and get same error
if i restart mysql, it returns to latin1

is character set really the issue?
do i need directory user permissions to create the db from rails?

rails 2.3.3
ruby 1.8.7
mysql 5.1.39

<code>
mysql Ver 14.14 Distrib 5.1.39, for apple-darwin9.5.0 (i386) using
readline 5.1

Connection id: 438
SSL: Not in use
Current pager: stdout
Using outfile: ''
Using delimiter: ;
Server version: 5.1.39 MySQL Community Server (GPL)
Protocol version: 10
Connection: Localhost via UNIX socket
Client characterset: latin1
Server characterset: latin1
UNIX socket: /tmp/mysql.sock
Uptime: 14 min 32 sec
</code>

so is this mysql default charset as latin1 really a problem?

I am having a similar problem. Did you find a solution?

I had this same issue with an older project but not with a new
project, so I copied the newer database.yml file to the older project,
renamed the database in the file, and then things worked. My new entry
looks like this:

development:
  adapter: mysql
  encoding: utf8
  reconnect: false
  database: dev
  pool: 5
  username: strike
  password: secret

i still have not found a solution to this problem
i have reached out to a few sources for help
my most detailed list of issues can be found here:

http://railsforum.com/viewtopic.php?pid=113115

its very frustrating...cannot create a db using mysql on mac

Using a different version of mysql solved this problem for me:

5.1.41 Mac OS X 10.5 (x86_64) --- doesn't work

5.1.41 Mac OS X 10.5 (x86) -- works

Using a different version of mysql solved this problem for me:

5.1.41 Mac OS X 10.5 (x86_64) — doesn’t work

5.1.41 Mac OS X 10.5 (x86) – works

I have successfully installed MySQL 5.1.41 on Snow Leopard using MacPorts 1.8.1 and the file

type is as follows:

/opt/local/bin/mysql5: Mach-O 64-bit executable x86_64

-Conrad