Issue while deploying to heroku with Rails 3.2.1, ruby 1.9.3-p0, using twitter/bootstrap.

Hi,

I am new to Rails and am following Rails tutorials by Michael Hartl and
Rails guides. I have deployed an app to Heroku, but I get this error
while trying to access it (from heroku logs) -

Completed 500 Internal Server Error in 75ms
ActionView::Template::Error (application.css isn't precompiled):
<%= stylesheet_link_tag "application", :media => "all" %>

I have used twiiter/bootstrap and have followed instructions on
https://github.com/seyhunak/twitter-bootstrap-rails

Here are the contents of my gemfile -
gem 'rails', '3.2.1'

# Bundle edge Rails instead:
# gem 'rails', :git => 'git://github.com/rails/rails.git'

group :development, :test do
  gem 'sqlite3'
  gem 'heroku'
  gem 'rspec-rails'
  gem 'twitter-bootstrap-rails'
  gem 'annotate', '~> 2.4.1.beta1'
end

group :test do
  gem 'webrat', '0.7.1'
end

group :production do
  gem 'pg'
end

# Gems used only for assets and not required
# in production environments by default.
group :assets do
  gem 'sass-rails', '~> 3.2.3'
  gem 'coffee-rails', '~> 3.2.1'

  # See https://github.com/sstephenson/execjs#readme for more supported
runtimes
  gem 'therubyracer'

  gem 'uglifier', '>= 1.0.3'
end

gem 'jquery-rails'

However the thing I don't understand is that I don't see any bootstrap
related css or js files in my /vendor/assets /javascripts or
/stylesheets dirs. I have bootstrap.js.coffee and bootstrap.css.less in
my /app/assets /javascripts and /stylesheets dirs respectively.

I am able to run the app. locally but it gives me the above error on
heroku.

Please help me with this issue.

Thanks in advance,
Manoj.

Hi,

I am new to Rails and am following Rails tutorials by Michael Hartl and
Rails guides. I have deployed an app to Heroku, but I get this error
while trying to access it (from heroku logs) -

Completed 500 Internal Server Error in 75ms
ActionView::Template::Error (application.css isn't precompiled):
<%= stylesheet_link_tag "application", :media => "all" %>

have you tried
rake assets:precompile

Thanks Noel, I tried that and got this error -

rake aborted!
couldn’t find file ‘twitter/bootstrap’
(in … /app/assets/javascripts/application.js:9)

One of the lines in my application.js is //= require twitter/bootstrap
Similarly application.css contains *= require twitter/bootstrap

Do I need to put twitter/bootstrap files manually in /vendor/assets folder?

Thanks Noel, I tried that and got this error -
rake aborted!
couldn't find file 'twitter/bootstrap'
   (in .. /app/assets/javascripts/application.js:9)

One of the lines in my application.js is //= require twitter/bootstrap
Similarly application.css contains *= require twitter/bootstrap

Do I need to manually include twitter/bootstrap files in my
/vendor/assets folder?

there are numerous ways to get twitter-bootstrap into rails (45 gems
on github last time I counted...) - you either already have on of the
twitter-bootstrap-gems in your gemfile and this either misconfigured
or missing: You can check out

http://blog.crowdint.com/2012/02/03/bootstrap-in-the-asset-pipeline.html

and then need to check why your bootstrap-assets are not found,
preferably locally first.

Moving the gem 'twitter-bootstrap-rails' out of "group :development,
:test" worked for me.

vierundsechzig@googlemail.com wrote in post #1045141: