IRB problem (rb1.9.1 +rails3.0 )

first post in this forum...
I have ubuntu 10.04Lts / rb1.9.1+ rails 3.0...
when I am trying to use irb... ($rails console) I get this...
I have tried to reinstall everything(irb ruby readline by synaptic)
but nothing came up
any help would be nice ! thanks in advance... !

mihaill@mihaill-laptop:~/www/blog$ rails console
/usr/local/lib/ruby/1.9.1/irb/completion.rb:9:in `require': no such
file to load -- readline (LoadError)
    from /usr/local/lib/ruby/1.9.1/irb/completion.rb:9:in `<top
(required)>'
    from /usr/local/lib/ruby/gems/1.9.1/gems/railties-3.0.0/lib/rails/
commands/console.rb:3:in `require'
    from /usr/local/lib/ruby/gems/1.9.1/gems/railties-3.0.0/lib/rails/
commands/console.rb:3:in `<top (required)>'
    from /usr/local/lib/ruby/gems/1.9.1/gems/railties-3.0.0/lib/rails/
commands.rb:20:in `require'
    from /usr/local/lib/ruby/gems/1.9.1/gems/railties-3.0.0/lib/rails/
commands.rb:20:in `<top (required)>'
    from script/rails:6:in `require'
    from script/rails:6:in `<main>'a

If you are using RVM:
rvm package install readline
rvm remove 1.9.1
rvm install 1.9.1 -C --with-readline-dir=$HOME/.rvm/usr

Otherwise try:

sudo apt-get install build-essential
sudo apt-get install bison byacc gperf
sudo apt-get install zlib1g-dev
sudo apt-get install libreadline5 libreadline5-dev
sudo apt-get install libncurses5 libncurses5-dev temcap-compat
sudo apt-get install libssl-dev

Hope that helps.

first post in this forum...
I have ubuntu 10.04Lts / rb1.9.1+ rails 3.0...

I believe Ruby 1.9.1 is not compatible with Rails 3 (see the Rails
Guide, Getting Started). You should upgrade to 1.9.2 I think. Of
course this may or may not be the cause of your particular problem.

Colin

ruby 1.9.1 is not supported use 1.9.2