install problems

I tried to follow the instructions on the web for mac OSX but got this
error

./mkconfig.rb:191: [BUG] Segmentation fault
ruby 1.8.6 (2007-03-13) [i686-darwin9.1.0]

make: *** [.rbconfig.time] Abort trap