including gems in rails projects. Gemonrails error.

I'm trying to load mechanize to my rails app with gemsonrails, but when
I try to start up my server I get this error:

"ERROR: Please update cygdrive/c/Documents and
Settings/Feng/ruby/project/playerman/vendor/gems/mechanize-0.7.6/init.rb
with the require path for linked RubyGem mechanize"

Also tried doing a require 'mechanize' on my controller, I get this:

"can't activate rubyforge (>= 1.0.0), already activated
rubyforge-0.4.5]"

how exactly do you include gems, and where? I read you're suppose to
include it in the environment.rb file.

thanks

Feng Tien wrote:

I'm trying to load mechanize to my rails app with gemsonrails, but when
I try to start up my server I get this error:

"ERROR: Please update cygdrive/c/Documents and
Settings/Feng/ruby/project/playerman/vendor/gems/mechanize-0.7.6/init.rb
with the require path for linked RubyGem mechanize"

Also tried doing a require 'mechanize' on my controller, I get this:

"can't activate rubyforge (>= 1.0.0), already activated
rubyforge-0.4.5]"

how exactly do you include gems, and where? I read you're suppose to
include it in the environment.rb file.

thanks

You can unpack any installed gem into the vendor folder under your app.

See: http://www.rubygems.org/read/chapter/10

Section 2.16 is what you want to read.