how to i force apche to handle download requestrunning apach

hii all, Am running apche as frontend to mongrel ,i added these line in Apache's httpd.conf file

LoadModule rewrite_module modules/

LoadModule proxy_module modules/

LoadModule proxy_balancer_module modules/

LoadModule proxy_http_module modules/

LoadModule xsendfile_module modules/

XSendFile on

XsendFileAllowAbove on

<VirtualHost *:80>

ServerName src

DocumentRoot C:/InstantRails-2.0-win/rails_apps/src/public/

ProxyPass / http://localhost:3000/

ProxyPassReverse / http://localhost:3000 </VirtualHost>

Now in my application i have to downlaod large stream and i don't want rails to serve it,i would like apache to server this request but with current setting rail i serving this request.

this is my code for download

filename = "#{@stream.location}"

response.headers['Content-Type'] = "application/force-download"

response.headers['Content-Disposition'] = "attachment; filename=\"#{File.basename(filename)}\""

response.headers["X-Sendfile"] = filename

response.headers['Content-length'] = File.size(filename)

render :nothing => true

with current setting am able to downlaod files of 1.1. gb only once to download it again i have to restart both mongrel and apache...