how to avoid pre-compile on deployment ..

I commented the following code in my deploy.rb , to avoid pre-
compiling upon deployment ..

# namespace :assets do
# desc "Compile assets"
# task :precompile, :roles => :app do
# run "cd #{release_path} && rake RAILS_ENV=#{rails_env}
assets:precompile"
# end
# end

but it seems to have no effect .... cap deploy log show precompiling
again...
.....
    triggering after callbacks for `deploy:update_code'
  * executing `deploy:assets:precompile'
  * executing "cd /var/www/vhosts/videopromo.tv/rails/videopromo/
releases/20120103234418 && bundle exec rake RAILS_ENV=production
RAILS_GROUPS=assets assets:precompile"

I have an issue with the .swf file being pre-compiled and I don't
want that ..
so I run a local pre-compile before deployment ...
rake assets:precompile --trace with config.assets.digest = false in
production.rb
and that was fine ... I got the files player.swf and ova-jw.swf
in public/assets/jwplayer folder

then I put back config.assets.digest = true in production.rb and did
my cap deploy
but on the remote production server , in public/assets I have
player.swf and ova-jw.swf BUT also
ova-jw-cd5839fa631138fe59903b79af552531 and
player-62ab06eeb4e8b316fd0e530ae810c579
seems not to be an issue for the player.swf , but it's definitely an
issue for the ova-jw.swf which is a plugin and need dynamic
settings ...

feedback will appreciated on how to solve this issue ( the ova-jw.swf
plug is running fine in local development mode, but
cannot be set up in production ...