HELP under PROXY!!!

Hello,
I've been learning RoR for a week now and I gotta say the learning
courve is awesome with this framework. However, with the introduction
of rails 2.0 some things became a little bit fuzzy, and since I am
dealing with it on a daily basis I accidentally installed Rails 2.0
unaware of all the problems it would cause me.
With some functions such as scaffolding being sent to the vendor/
plugins folder, it appears that each time we want to use some
facilitating cool feature under rail, we're obliged to be connected to
the internet, to fetch the correspondent plugin in the repository.
Well, correct me if I'm wrong, but I guess this the way RoR handles it
and for me it's a big pain! I'm not connected all the time, having to
work on planes or trains, so I can't get instant access to everything
I need in my projects. And, the greatest problem of all:
I'm behind a PROXY!

As some threads have already came up to, the command script/plugin
does not behave very well under a proxy. There's been trouble with
authenticating proxies and when you're not sure if you are or not
behind one (believe, it can be the case for some), the script doesn't
even give you a clue as of what is happening. In my case, my proxy
server in the university does not require authentication, but there's
this thing of setting an env. variable http_proxy that some people
talk about which is, for me, a complete mistery!!! I don't know how to
set it, if I have a slight clue I have no means to know if it's been
done right and so on...

To sum things up, could any charitative soul post a detailed step-by-
step guide showing how to get through proxies so as to enable plugin
fetching over the internet??? At least until the plugin script get
some proxy functionality itself, which would be very useful, or until
attepts to download the code and install locally no longer return an
error that says things no one understand about ROOT_PATH or something
like it.

And no, I don't want to go back to previous versions, since I think
it's useless to ignore these problems as newer version will be
arriving anyway.

Thanks in advance!!!