[Help] Rake test:functionals failed.

Hi all,
Im a new user for using Rails,
I got the 3 error msg as belows,

/usr/bin/ruby1.8 -I"lib:test" "/home/mioinst/.gem/ruby/1.8/gems/
rake-0.8.7/lib/rake/rake_test_loader.rb" "test/functional/
way_controller_test.rb" "test/functional/
diary_entry_controller_test.rb" "test/functional/
amf_controller_test.rb" "test/functional/relation_controller_test.rb"
"test/functional/swf_controller_test.rb" "test/functional/
message_controller_test.rb" "test/functional/
changeset_tag_controller_test.rb" "test/functional/
node_controller_test.rb" "test/functional/old_node_controller_test.rb"
"test/functional/search_controller_test.rb" "test/functional/
user_preference_controller_test.rb" "test/functional/
user_controller_test.rb" "test/functional/old_way_controller_test.rb"
"test/functional/trace_controller_test.rb" "test/functional/
api_controller_test.rb" "test/functional/friend_controller_test.rb"
"test/functional/old_relation_controller_test.rb" "test/functional/
geocoder_controller_test.rb" "test/functional/
changeset_controller_test.rb" "test/functional/
browse_controller_test.rb" "test/functional/export_controller_test.rb"
"test/functional/site_controller_test.rb"
Loaded suite /home/mioinst/.gem/ruby/1.8/gems/rake-0.8.7/lib/rake/
rake_test_loader
Started
................................F.F.F...............................................................................................................................................
Finished in -3824716.83084 seconds.

  1) Failure:
test_changes_simple(ApiControllerTest) [/test/functional/
api_controller_test.rb:204]:
Expected response to be a <:success>, but was <500>
<"">

  2) Failure:
test_changes_zoom_valid(ApiControllerTest)
    [/test/functional/api_controller_test.rb:228:in
`test_changes_zoom_valid'
     /test/functional/api_controller_test.rb:226:in `upto'
     /test/functional/api_controller_test.rb:226:in
`test_changes_zoom_valid']:
Expected response to be a <:success>, but was <500>
<"">

  3) Failure:
test_hours_valid(ApiControllerTest)
    [/test/functional/api_controller_test.rb:257:in `test_hours_valid'
     /test/functional/api_controller_test.rb:255:in `upto'
     /test/functional/api_controller_test.rb:255:in
`test_hours_valid']:
Expected response to be a <:success>, but was <500>
<"">

180 tests, 2341 assertions, 3 failures, 0 errors

I have no idea how to fix this problem, Could someone know how to fix
this please?
Thank you so much.

Best Wishes,
Neckie.

If you look in test.log you may get some clues as to why you are
getting the 500 error.
Have you setup database.yml to refer correctly to the test database?

Colin

Dear Colin,
Thanks for you help. I've already fix this problem.

Thank you so much. ^^