gem question on hosted service

All,

This may be a gem question (not rails) but I feel sure someone else on
this list has seen this issue go by. I use a hosting service that has
ROR available, but I am among the few developers using it. I am
developing on a local linux box, and have been very careful to NOT use
any extra gems because I might have a problem with my provider.

Well ... fastercsv rocks and I wanted to use it.

My provider has a method for me to install a gem, and I did so with
their interface (Fansastico).

My issue:
require 'fastercsv' does not work, and I think it's because they put
gems in a place where ruby/rails can't seem to find them. This is the
message given when I look at my installed gems:

Using Your Ruby Gem(s)

You will need to add /home/user1/ruby/gems to the include path.
You can do this by adding the following code to your script:

$:.push("/home/user1/ruby/gems")

I have placed this code in the environment.rb file, and in a couple of
other locations that I thought might help with no success.

Is there a way to require a gem from a strange location, or do I need
to add something to my path or environment variables to help ruby
figure out where these are stored?

Any help is much appreciated .....

Dustin

Things I tried:

ENV['GEM_PATH'] ||= '/home/user1/ruby/gems'

or

config.load_paths += %W( /home/user1/ruby/gems/gems )

or

$:.push("/home/user1/ruby/gems")
require 'fastercsv'

(all these result in rails failing to start)

Things I tried:

ENV['GEM_PATH'] ||= '/home/salgba/ruby/gems'

Something along the lines of this one feels like the right thing. What
happens when you do this?

Fred

Tried it, still doesn't make a difference.
I guess I can attempt support at my hosting company, but I think I am
one of a few customers using rails, so I may be back here soon.

Thanks for your help !!