gem_original_require no such file to load -- /var/www/vhosts/gophotoswap.com/httpdocs/current/config/environment ( LoadError )

** Daemonized, any open files are closed. Look at /var/www/vhosts/
gophotoswap.com/httpdocs/shared/pids/mongrel.8000.pid and /var/www/
vhosts/gophotoswap.com/httpdocs/shared/log/mongrel.8000.log for info.
** Starting Mongrel listening at 127.0.0.1:8000
** Initiating groups for "mongrel":"mongrel".
** Changing group to "mongrel".
** Changing user to "mongrel".
** Starting Rails with production environment...
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require': no such file to load -- /var/www/vhosts/
gophotoswap.com/httpdocs/current/config/environment (LoadError)
  from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
27:in `require'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/
mongrel/rails.rb:147:in `rails'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/
mongrel_rails:113:in `cloaker_'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/
mongrel/configurator.rb:149:in `call'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/
mongrel/configurator.rb:149:in `listener'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/
mongrel_rails:99:in `cloaker_'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/
mongrel/configurator.rb:50:in `call'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/
mongrel/configurator.rb:50:in `initialize'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/
mongrel_rails:84:in `new'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/
mongrel_rails:84:in `run'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/
mongrel/command.rb:212:in `run'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/
mongrel_rails:281
  from /usr/local/bin/mongrel_rails:19:in `load'
  from /usr/local/bin/mongrel_rails:19

This has been solved.

Make sure all permissions on the symlink current, the dirs shared/pids
shared/log, shared/tmp are all set to 755