From Development to production, Error

Hi you all,

I have an app working correctly in Development mode.

For changing to Production I have:
- Copied database schema and data from myapp_development database to
myapp_production database.
- Executed the script/server with "--environment=production".

And when accesing the app I get this error:

Mysql::Error in BugsController#index
#28000Access denied for user 'root'@'localhost' (using password: YES)

Why I get this error? In fact, when accesing to http://localhost:3000/,
when click on "About your application's environment", I get:

Routing Error
no route found to match "/rails/info/properties" with {:method=>:get}

suggestions? :frowning:

Hi you all,

I have an app working correctly in Development mode.

For changing to Production I have:
- Copied database schema and data from myapp_development database to
myapp_production database.
- Executed the script/server with "--environment=production".

And when accesing the app I get this error:

Mysql::Error in BugsController#index
#28000Access denied for user 'root'@'localhost' (using password: YES)

Why I get this error?

Because your production server has a different password for the root mysql user? (Perhaps you're not even supposed to be using the root user, I certainly wouldn't).

Fred

No... it's the same server, with the tree database there (test,
development, production)... The database.yaml is also correct.

I feel idiot. Yeah, I mistyped the pwd for the production database :frowning:
However, when accesing to http://localhost:3000/,
when click on "About your application's environment", I get:

"The page you were looking for doesn't exist.
You may have mistyped the address or the page may have moved."

I don't care, cause I'm gonna make my own index page, but I wonder what
the problem is.

Damaris Fuentes wrote:

It may be related to this:

     http://dev.rubyonrails.org/ticket/8349

That patch is a bit old, I have not checked whether it still can be applied cleanly.

-- fxn

Um, ok, thanks :slight_smile: