[Feature Proposal] Add beginning_of_half_year or beginning_of_biannual

Hi Folks, I would like to propose adding the new method to find the beginning of the half-year. The method is really useful for the application used for the financial purpose and can come handy.

I can raise a patch to add the method. Already added a patch in our application so it would be easier.


1 Like

I like the idea! I’m wondering if biannual would be unclear wording to folks. Maybe I’m being overly cautious thinking about that though.

Yeah. Even I felt it bit weird to use biannual. I would go with half_year for now.

semiannual would be a better name than biannual. It doesn’t have the ambiguity that biannual does.

1 Like

Not sure about adding to Rails, but we’ve found the fiscali gem very good for these sorts of things https://github.com/asanghi/fiscali

1 Like

Oh. Thanks you. It looks good. Doesn’t look we have the attention of Rails team here and this solving problem for many so it is better to go with gem or write our own for our applications. Maybe in future. :slight_smile: