Fastcgi + rails under plesk

Hello,

I have plesk 9.3 and I am trying to make it go along with rails. So I
installed ruby, rails, ruby-gems, fastcgi, etc. (I had tried
Passenger,
but it didn't work with my distro due to dependencies... so I
preferred
giving up).

When I run ./dispatch.fcgi in command-line, it outputs nothing and
continues executing until I press enter or whatever then it returns to
shell. When I try to access it on the web, I get an error 500. I
looked
at the logs and I have "Prematurend of script headers". I made some
searches without success... I'm wondering why it happens. Before
having
this blank output from ./dispatch.fcgi (in command-line), I had a
rails
error telling me that it needed a greater version of ruby-gems so I
upgraded and now I have nothing.. :confused:

Is there someone which could help me? This is my very first rails app,
and my very first deployment... It took me the day to set up
everything
(including capistrano with git, etc), I'm fed up..

(Sorry if I made some English mistakes, I'm not a native-speaker).

Thanks in advance!

Anyone? I need to make it work..