`exec': wrong number of arguments (ArgumentError) when using bundle exec

Hi! I’m trying to make a migration, but when I do “rake db:migrate” tell me this:

You have already activated rake 0.9.2, but your Gemfile requires rake 0.8.7. Consider using bundle exec.

Then, I use a bundle exec, but I have other error:

exec': wrong number of arguments (ArgumentError) from /usr/lib/ruby/gems/1.8/gems/bundler-1.0.15/lib/bundler/cli.rb:346:in exec’
from /usr/lib/ruby/gems/1.8/gems/bundler-1.0.15/lib/bundler/vendor/thor/task.rb:22:in send' from /usr/lib/ruby/gems/1.8/gems/bundler-1.0.15/lib/bundler/vendor/thor/task.rb:22:in run’
from /usr/lib/ruby/gems/1.8/gems/bundler-1.0.15/lib/bundler/vendor/thor/invocation.rb:118:in invoke_task' from /usr/lib/ruby/gems/1.8/gems/bundler-1.0.15/lib/bundler/vendor/thor.rb:246:in dispatch’
from /usr/lib/ruby/gems/1.8/gems/bundler-1.0.15/lib/bundler/vendor/thor/base.rb:389:in start' from /usr/lib/ruby/gems/1.8/gems/bundler-1.0.15/bin/bundle:13 from /usr/bin/bundle:19:in load’
from /usr/bin/bundle:19

Anyone know why show me this error?

Regards, Iván

When it says try using bundle exec… it means that you have to prefix the command with that

Use it like this ‘bundle exec rake db:migrate’

Yes, I understand. Thanks!

Regards, Iv�n