Errors When Trying to Update RubyGems on OS X Tiger

Hello there,

I am using the following:

Ruby version:

ruby 1.8.4 (2005-12-24) [powerpc-darwin8.7.0]

Rails version:

Rails 1.1.4

RubyGems version:

0.9.0

I got the following error message when I tried to update all my
RubyGems on OS X Tiger (please notice that I did log as 'root' prior
to this):

Raven:/Users/untz root# gem update all --include-dependencies
Updating installed gems...
Bulk updating Gem source index for: http://gems.rubyforge.org
Attempting remote update of all
ERROR: While executing gem ... (Gem::GemNotFoundException)
     Could not find all (> 0) in the repository
Raven:/Users/untz root# gem update --include-dependencies
Updating installed gems...
Attempting remote update of actionmailer
Successfully installed actionmailer-1.3.3
Successfully installed actionpack-1.13.3
Successfully installed activesupport-1.4.2
Installing ri documentation for actionmailer-1.3.3...
Installing ri documentation for actionpack-1.13.3...

RDoc failure in lib/action_controller/cgi_ext/raw_post_data_fix.rb at
or around line 36 column 22

Before reporting this, could you check that the file
you're documenting compiles cleanly--RDoc is not a
full Ruby parser, and gets confused easily if fed
invalid programs.

The internal error was:

ERROR: While executing gem ... (NoMethodError)
     undefined method `match_io' for -517611318:Fixnum

It also has errors when I try to run updates on other RubyGems!

Any help is greatly appreciated!

-Unnsse

maybe this is an aproach

http://weblog.rubyonrails.org/2005/12/22/is-gcc-4-0-incompatible-with-ruby-on-os-x-and-elsewhere/

Rafael,

Thanks for the response!

Well, actually this time the gem update worked!

And I didn't have to select a lower version of GCC than 4.0....

Makes me think that perhaps the Internet connections while doing a
gem update are buggy?

Happy programming,

Unnsse