error in authentasaurus

It's pretty hard to help when you've cut off the error message. The
text immediately above the backtrace is the most important part...

Even without that, however, my first advice would be to upgrade your
Rails version. Running on 2.0.5 is going to mean that most plugins you
find won't work, and you'll be tripping over bugs the community has
already fixed.

--Matt Jones