Encoding Issues Seeds.rb

Hi People,

Im running the seed.rd for the countries from here: https://github.com/wdblair/Rails-Seed-All-Countries-and-All-States/downloads the author states that the file is UTF.

When I execute the import I recieve the error: invalid multibyte char (UTF-8)’ (from instructions here: http://stackoverflow.com/questions/1739836/invalid-multibyte-char-us-ascii-with-rails-and-ruby-1-9)

I tried adding this to the top of the file: # encoding: utf-8 but still no luck.

I tried the instructions here: https://groups.google.com/forum/?fromgroups#!searchin/rubyonrails-talk/invalid$20multibyte$20char/rubyonrails-talk/KKXeimNmjV4/B5qfG9trqW8J

Still the same error occours.

Im using ruby: 1.9.2p290 (2011-07-09) [i386-mingw32] and rails: 3.1.3 running on windows.

Any ideas what I have wrong?



Hi All,

I rebuilt my enviroment on linux, still the same issue occours. Any one have any idea whats going on?



Your problem will probably go away if you write the following comment at the top of the .rb file:

encoding: utf-8


Hi Juan,

I have tried that, still recieve the same error. Also noticed running the seed on heroku also throws the same error.

Any other suggestions?




    Try to reconvert the file with "iconv -f UTF-8" and add "#

encoding: utf-8" to the first line…

    In case isn't working I will suggest to review the encoding of

the database and maybe to force it with “encoding: UTF8”


Hi All,

I tried everything and was going mad. I discovered redownloading the file and replacing my existing one fixed it after putting the utf header in. My guess is editing the file on windows somehow stuffed up the encoding (surprise surprise!).

Thank you everyone for their help!