Disabling a form ...

This is what I have:

<% remote_form_for :message,
   :url => { :action => 'add_followup' },
   :loading => "$('followup_form').disable();", :complete => "$('followup_form').enable;",
   :html => { :id => 'followup_form' } do |form| %>

   .......

<% end %>

It works fine on FF, but not on Safari.
Where's the mistake here ?

   ngw

Nicholas Wieland wrote:

('followup_form').enable;",

uh, enable() <-- ?

No ...
The problem is with disable(), it doesn't disable anything ...

   ngw

Nicholas Wieland wrote:

The problem is with disable(), it doesn't disable anything ...

Try viewing your page, using View Source, copy out the generated
JavaScript, and pasting it here.

<form onsubmit="new Ajax.Request('/issue/add_followup', {asynchronous:true, evalScripts:true, onComplete:function(request){$('followup_form').enable();}, onLoading:function(request){$('followup_form').disable();}, parameters:Form.serialize(this)}); return false;" method="post" id="followup_form" action="/issue/add_followup">

........

</form>

TIA,
   ngw

Nicholas Wieland wrote:

$('followup_form').enable();

I never had any luck with that. Try Form.Enable("followup_form") -
Google for it first!