Did 7.2 alpha got yanked?

hey :wave:

I have an app using Rails on the main branch like this

gem "rails", github: "rails/rails", branch: "main"

and as of this morning, I can’t build docker images with it:

#16 3.835 Fetching gem metadata from https://rubygems.org/...........
#16 9.936 Your bundle is locked to rails (7.2.0.alpha) from
#16 9.936 https://github.com/rails/rails.git (at main@a27a175), but that version can no
#16 9.936 longer be found in that source. That means the author of rails (7.2.0.alpha) has
#16 9.936 removed it. You'll need to update your bundle to a version other than rails
#16 9.936 (7.2.0.alpha) that hasn't been removed in order to install.
#16 ERROR: process "/bin/bash -o pipefail -c bundle config set app_config .bundle &&     bundle config set path /srv/vendor &&     bundle install &&     bundle clean &&     mkdir -p vendor &&     bundle config set path vendor &&     cp -ar /srv/vendor ." did not complete successfully: exit code: 7

I might be mistaken, but I thought that once you install a gem from GitHub, you don’t really need that gem to be pushed to RubyGems anymore, and checking RubyGems, it does appear that the v7.2.0.alpha was yanked (or was never there?)

has anyone seen something like this before?

It turns out Docker needed some cleaning up. docker system prune seemed to have solved the problem.

The Rails main branch was updated to to 8.0.0.alpha:

But it’s weird because it sure looks like the version at the commit that is referenced exists and is still 7.2.0.alpha, so I’m not sure why it didn’t get pulled down, unless for some reason GitHub temporarily burped.

1 Like

it was really weird. Since pruning Docker solved the problem, I considered it a Docker-related problem (image cache, maybe?). I haven’t seen this issue since.