There is a potential denial of service vulnerability present in ActiveRecord’s PostgreSQL adapter.
This has been assigned the CVE identifier CVE-2022-44566.
Versions Affected: All. Not affected: None. Fixed Versions: 184.108.40.206, 220.127.116.11
In ActiveRecord <18.104.22.168 and <22.214.171.124, when a value outside the range for a 64bit signed integer is provided to the PostgreSQL connection adapter, it will treat the target column type as numeric. Comparing integer values against numeric values can result in a slow sequential scan resulting in potential Denial of Service.
The fixed releases are available at the normal locations.
Ensure that user supplied input which is provided to ActiveRecord clauses do not contain integers wider than a signed 64bit representation or floats.
To aid users who aren’t able to upgrade immediately we have provided patches for the supported release series in accordance with our maintenance policy regarding security issues. They are in git-am format and consist of a single changeset.
- 6-1-Added-integer-width-check-to-PostgreSQL-Quoting.patch - Patch for 6.1 series
- 7-0-Added-integer-width-check-to-PostgreSQL-Quoting.patch - Patch for 7.0 series
Thank you Jeremy Evans for reporting this!