css background not showing

Hi all,

for some reason adding the following is doing nothing…

.post.hover {

background: FAFAFA;

I’ve got this in my posts.js coffee file

$ ->

$(’.post’).hover (event) ->

  	$(this).toggleClass("hover")

and my index is

<% @posts.each do |post| %>

  <strong><%= post.title %></strong>
  <p><%= post.content %></p>
  <div class="meta">
  	<%= link_to time_ago_in_words(post.created_at) + " ago", post %>
  	<span class="admin">
  	>	<%= link_to "Edit", edit_post_path(post) %> |
  		<%= link_to "Delete", post, :confirm => "Are you sure you want to delete this post?", :method => :delete %> |
  	</span>
  	<div>

<% end %>

Any ideas?

Hi,

for some reason adding the following is doing nothing...

Please note this list is for Rails questions, not HTML/CSS questions.

.post.hover {
background: FAFAFA;

FAFAFA is not a valid value for background, and you should be using
background-color if you only have a colour just for semantics but to
directly address your question, please try doing #fafafa, please also
note that the pseudo class for hover is :hover so try .post:hover
instead of .post.hover.

Hi all,
for some reason adding the following is doing nothing…

.post.hover {

background: FAFAFA;

I’ve got this in my posts.js coffee file

$ ->

$('.post').hover (event) ->
  	$(this).toggleClass("hover")

and my index is

<% @posts.each do |post| %>
<div class="post">
  <strong><%= post.title %></strong>
  <p><%= post.content %></p>
  <div class="meta">
  	<%= link_to time_ago_in_words(post.created_at) + " ago", post %>
  	<span class="admin">
  	>	<%= link_to "Edit", edit_post_path(post) %> |
  		<%= link_to "Delete", post, :confirm => "Are you sure you want to delete this post?", :method => :delete %> |
  	</span>
  	<div>
</div>
<% end %>

Any ideas?

can you check it via firebug or chrome’s developer tools and check if the class really toggles (i’m pretty it does). if you can’t

see the changes maybe the change isn’t that obvious. FAFAFA is very close to white so if you have a white background, you

may not notice the change.

it not work.

background: FAFAFA;

it work.

background: #FAFAFA;

"background: #FAFAFA" ??

That was it…

for some reason kept overlooking that I didn’t have the #…

Sorry all.