Create rails app using old version of rails

Hi all,

This may be a silly question, but how can we create a new rails
(skeleton) app using an older version of rails on the system?
Say I've installed rails 2.0 (RC), and now I want to create a rails
1.2.5 app (the corresponding gems already installed). how could I do
that?

Thanks.

It's pretty easy. Specify the full path to rails in your 1.2.5 gems
folder. On my system, that is usr/local/lib/ruby/gems/1.8/gems/
rails-1.2.4/bin/rails. Make sure that the new app has the proper
version set in environment.rb. Thats it.

-Bill

Thanks, I will try.

Alternatively:

  rails _1.2.5_ appname

(Works for any executable in a gem. :slight_smile: