I'm currently reading "Agile Web Development" and doing the tutorial
(Depot). It says that the naming conventions are that the Controller
needs to be singular (even though I found other naming conventions on
the net, anybody knows the official naming conventions?) therefore I
have a UserController. When I try to test the controller I get this
error:
NameError: uninitialized constant UsersController
right here:
assert_redirected_to user_path
Why does it want a UsersController? I thought singular is the way to go?
Confused.
On Dec 21, 5:15�pm, Heinz Strunk <rails-mailing-l...@andreas-s.net>
Yep, pretty sure:
"Rails assumes the class is called StoreController and that it’s in a
file
named store_controller.rb in the app/controllers directory."