Can't Install Rails. Can any one help Please!

Try this:

gem install rails --source http://gems.rubyforge.org

This won't fix the problem with Gem though.
What is the Gem environment?

gem env