cannot launch IRB on Mac OS X Leopard

I successfully installed Ruby 1.8.6 and Rails 2.0.2 and RubyGems 1.0.1.
Launched ruby script/server. Got successful Welcome Aboard ROR page in
browser. Opened second Terminal window and tried to launch irb. Got
this failure message:

    $ irb
    dyld: NSLinkModule() error
    dyld: Symbol not found: _rl_filename_completion_function
      Referenced from:
/usr/local/lib/ruby/1.8/i686-darwin9.2.2/readline.bundle
      Expected in: flat namespace

    Trace/BPT trap

I tried this in all directories from the app directory on up. Even
tried with sudo

Any ideas?

Ruby comes with Leopard, you shouldn't of needed to install anything.
When you say you installed it yourself what did you do exactly to
accomplish this?

What happens when you type:

   ruby --version

You should see this:
ruby 1.8.6 (2007-09-24 patchlevel 111) [universal-darwin9.0]

If not you didn't install it correctly. Let me know if you get that
far and I'll see what else I can think of.

Nicholas

ncancelliere wrote:

Ruby comes with Leopard, you shouldn't of needed to install anything.
When you say you installed it yourself what did you do exactly to
accomplish this?

What happens when you type:

   ruby --version

You should see this:
ruby 1.8.6 (2007-09-24 patchlevel 111) [universal-darwin9.0]

If not you didn't install it correctly. Let me know if you get that
far and I'll see what else I can think of.

Nicholas

On May 27, 5:17�pm, David Crellen <rails-mailing-l...@andreas-s.net>

My version is: ruby 1.8.6 (2008-03-03 patchlevel 114)
[i686-darwin9.2.2]. It is newer than from Leopard and I followed
precisely the instructions in Patrick Lenz book "Simply Rails 2". I do,
indeed get the opening splash in the browser (http://localhost:3000)
and "About your application's environment reports this:
    Ruby version 1.8.6 (i686-darwin9.2.2)
    RubyGems version 1.0.1
    Rails version 2.0.2
    Active Record version 2.0.2
    Action Pack version 2.0.2
    Active Resource version 2.0.2
    Action Mailer version 2.0.2
    Active Support version 2.0.2
    Application root /Users/david/shovell
    Environment development
    Database adapter sqlite3

But I cannot get past this point.