Can someone apply these verified patches?

I'm hoping someone from core would be willing to commit this one:

http://dev.rubyonrails.org/ticket/10565

And also to just get a thumbs-up or down on this one, one way or the
other. We've had several opinions and I think it's in need of an
"official Rails opinion" at this point:

http://dev.rubyonrails.org/ticket/10569

Thanks!
Jeff