Bump minimum SQLite version to 3.8 for Rails 6

Hi,

I'd like to propose that Rails 6 requires SQLite 3.8 or higher.

These OS versions have SQLite 3.8 or higher by default.

- macOS 10.10 (Yosemite) or higher
- Ubuntu 14.04 LTS or higher

There was a similar discussion for Rails 5 two years ago, yes I
requested that one.
https://groups.google.com/forum/#!topic/rubyonrails-core/Mm4ZN_g1RXk

Since two years passed since my previous request, Ubuntu 12.04 LTS
support has been dropped and newer macOS versions have been released.
I think it is good time to bump the minimum version of SQLite for
Rails 6.

Also, bumping SQLite version 3.8 will allow supporting `alter_table`
method for the table with foreign keys by this pull request:

"Disable foreign keys during `alter_table` for sqlite3 adapter"
https://github.com/rails/rails/pull/32865
requires SQLite 3.8 to support `defer_foreign_keys` pragma.

Please review my proposal. I am ready to open a pull request.

Thanks,

This proposal has been implemented for Rails 6 by this pull request https://github.com/rails/rails/pull/32923

Thanks,